Konfigurasi MikroTik Untuk Limit Bandwidth

Assalamualaikum,

Kali ini saya ingin posting bagaimana caranya mengkonfigurasi router untuk membatasi (limit) penggunaan bandwidth. Yah seperti biasa saya menulis agar bermanfaat bagi diri sendiri dan juga bagi sesama, soalnya terkadang itu saya juga tipe orang pelupa. Hehehe

Baiklah langsung saja kita mulai belajar. Siapkan dulu alat dan bahan-bahannya :

  1. Router MikroTik.
  2. PC Client.
  3. Switch atau Hub.
  4. Kabel UTP.
  5. Layanan Access Internet.

Begini contoh topologi jaringan saya

topologi

Sebelum  melakukan  pengaturan  bandwidth,  pada  router  mikrotik  konfigurasi
hal-hal berikut :

  • Interface yang dipakai untuk menghubungkan MikroTik dengan jaringan
    internet beri nama public.
  • Interface  yang  dipakai  untuk  menghubungkan  MikroTik  dengan  jaringan
    Local  beri nama local.
  • Konfigurasi Routing
  • Konfigurasi NAT
  • Konfigurasi IP Address tiap-tiap Client
  1. Manajemen bandwidth jenis queue simple

Queue  Simple  merupakan  cara  sederhana  melakukan  limit  data  rate  untuk  IP
Address atau subnet. Perhatikan illustrasi berikut :

Screenshot_1

Berikut ini adalah langkah-langkah konfigurasi queue simple :
a. Melalui aplikasi Winbox, pilih menu New Terminal.
b. Berikut ini adalah perintah konfigurasi queue simple.

[admin@MikroTik] > queue simple
[admin@MikroTik] /queue simple> add name=limit-client1
interface=lan target-address=192.168.1.2/32
maxlimit=64000/128000
[admin@MikroTik] /queue simple> add name=limit-client2
interface=lan target-address=192.168.1.3/32
maxlimit=64000/128000
[admin@MikroTik] /queue simple> add name=limit-client3
interface=lan target-address=192.168.1.4/32
maxlimit=64000/128000
[admin@MikroTik] /queue simple> print
Flags: X – disabled, I – invalid, D – dynamic
0  name=”limit-client1″ target-addresses=192.168.1.2/32

dst-address=0.0.0.0/0 interface=lan parent=none
direction=both
priority=8 queue=default-small/default-small limit-at=0/0
max-limit=64k/128k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small

1  name=”limit-client2″ target-addresses=192.168.1.3/32
dst-address=0.0.0.0/0 interface=lan parent=none
direction=both
priority=8 queue=default-small/default-small limit-at=0/0
max-limit=64k/128k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small
2  name=”limit-client3″ target-addresses=192.168.1.4/32
dst-address=0.0.0.0/0 interface=lan parent=none
direction=both
priority=8 queue=default-small/default-small limit-at=0/0
max-limit=64k/128k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small
[admin@MikroTik] /queue simple>

Keterangan :
add  name=limit-client1,  menfinisikan  nama  dari  queue  simple  untuk
konfigurasi komputer client 1.
Interface=local, merupakan antarmuka/interface untuk gateway client.
target-addresses=192.168.1.2/32, merupakan IP address milik komputer
Client1.
max-limit=64000/128000, merupakan limit maksimum  komputer client untuk
uplink 64 kbps dan downlink 128 kbps.

2. Manajemen bandwidth jenis queue tree

Queue  Tree  merupakan  limit  bandwidth  yang  kompleks  karena  pelimitan
dapat dikelompokkan  berdasarkan  portokol,  ports  atau  kelompok  IP  Address.
Sebelum melakukan  pelimitan,  terlebih  dahulu  harus  dilakukan  penandaan  paket
aliran  paket menggunakan  suatu  tanda  mangle  agar  paket  tersebut  dikenal  oleh
queue  tree.  Mangle adalah istilah yang dipakai pada mikrotik.  Hal ini bertujuan
untuk membedakan paket yang downlink only dan uplink only sehingga limit pada
bandwidth dapat bekerja optimal.
Berikut adalah implementasi queue tree, semua client akan dibatasi dengan
limit downlink (interface  local)  192  kbps  dan  uplink  (antarmuka  public)  96
kbps.  Sementara  bandwidth uplink  untuk  tiap-tiap  client  adalah  32  kbps  dan
downlink  64  kbps.  Perhatikan  illustrasi berikut :

Screenshot_2

Berikut ini adalah proses konfigurasi queue tree :
a. Konfigurasi mangle untuk client 1

[admin@MikroTik] > ip firewall mangle
[admin@MikroTik] /ip firewall mangle> add src-address=
192.168.1.2/32 action=mark-connection newconnectionmark=mark-client1
chain=prerouting

[admin@MikroTik] /ip firewall mangle> add connectionmark=markclient1
action=mark-packet
new-packet-mark=client1

chain=prerouting

[admin@MikroTik] /ip firewall mangle> print
Flags: X – disabled, I – invalid, D – dynamic

0  chain=prerouting action=mark-connection newconnectionmark=mark-client1
passthrough=yes
srcaddress=192.168.1.2

1  chain=prerouting action=mark-packet new-packet-mark=client1
passthrough=yes connection-mark=mark-client1
[admin@MikroTik] /ip firewall mangle>

b. Konfigurasi queue tree untuk client 1

[admin@MikroTik] /ip firewall mangle> /queue tree
[admin@MikroTik] /queue tree> add name=client1-downlink parent=lan
limit-at=96000 packet-mark=client1 max-limit=192000
[admin@MikroTik] /queue tree> add name=client1-uplink parent=wan
limit-at=32000 packet-mark=client1 max-limit=64000
[admin@MikroTik] /queue tree> print
Flags: X – disabled, I – invalid
0  name=”client1-downlink” parent=local packet-mark=client1
limit-at=96k queue=default priority=8 max-limit=192k
burstlimit=0 burst-threshold=0 burst-time=0s
1  name=”client1-uplink” parent=public packet-mark=client1
limitat=32k queue=default priority=8 max-limit=64k burstlimit=0
burst-threshold=0
burst-time=0s

[admin@MikroTik] /queue tree>

c. Konfigurasi mangle untuk client 2

[admin@MikroTik] /queue tree> /ip firewall mangle
[admin@MikroTik] /ip firewall mangle> add
srcaddress=192.168.1.3/32 action=mark-connection newconnectionmark=mark-client2
chain=prerouting

[admin@MikroTik] /ip firewall mangle> add connectionmark=markclient2
action=mark-packet
new-packet-mark=client2

chain=prerouting

[admin@MikroTik] /ip firewall mangle> print
Flags: X – disabled, I – invalid, D – dynamic
0  chain=prerouting action=mark-connection new-
connectionmark=mark-client1 passthrough=yes srcaddress=192.168.1.2

1    chain=prerouting action=mark-packet new-packet-mark=client1
passthrough=yes connection-mark=mark-client1
2  chain=prerouting action=mark-connection newconnectionmark=mark-client2
passthrough=yes
srcaddress=192.168.1.3

3  chain=prerouting action=mark-packet new-packet-mark=client2
passthrough=yes connection-mark=mark-client2
[admin@MikroTik] /ip firewall mangle>

d. Konfigurasi queue tree untuk client 2

[admin@MikroTik] /ip firewall mangle> /queue tree
[admin@MikroTik] /queue tree> add name=client2-downlink parent=lan
limit-at=96000 packet-mark=client2 max-limit=192000
[admin@MikroTik] /queue tree> add name=client2-uplink parent=wan
limit-at=32000 packet-mark=client2 max-limit=64000
[admin@MikroTik] /queue tree> print
Flags: X – disabled, I – invalid
0 name=”client1-downlink” parent=local packet-mark=client1
limit-at=96k queue=default priority=8 max-limit=192k
burstlimit=0 burst-threshold=0 burst-time=0s

1 name=”client1-uplink” parent=public packet-mark=client1
limitat=32k queue=default priority=8 max-limit=64k burstlimit=0
burst-threshold=0
burst-time=0s

2 name=”client2-downlink” parent=local packet-mark=client2
limit-at=96k queue=default priority=8 max-limit=192k
burstlimit=0 burst-threshold=0 burst-time=0s

3 name=”client2-uplink” parent=public packet-mark=client2
limitat=32k queue=default priority=8 max-limit=64k burstlimit=0
burst-threshold=0
burst-time=0s

Konfigurasi mangle untuk client 3

[admin@MikroTik] /queue tree> /ip firewall mangle
[admin@MikroTik] /ip firewall mangle> add
srcaddress=192.168.1.4/32 action=mark-connection newconnectionmark=mark-client3
chain=prerouting

[admin@MikroTik] /ip firewall mangle> add connectionmark=markclient3
action=mark-packet
new-packet-mark=client3

chain=prerouting

[admin@MikroTik] /ip firewall mangle> print
Flags: X – disabled, I – invalid, D – dynamic
0  chain=prerouting action=mark-connection new-
connectionmark=mark-client1 passthrough=yes srcaddress=192.168.1.2

1   chain=prerouting action=mark-packet new-packet-mark=client1
passthrough=yes connection-mark=mark-client1
2   chain=prerouting action=mark-connection newconnectionmark=mark-client2
passthrough=yes
srcaddress=192.168.1.3

3   chain=prerouting action=mark-packet new-packet-mark=client2
passthrough=yes connection-mark=mark-client2
4  chain=prerouting action=mark-connection newconnectionmark=mark-client3
passthrough=yes
src-
address=192.168.1.4
5  chain=prerouting action=mark-packet new-packet-mark=client3
passthrough=yes connection-mark=mark-client3

f. Konfigurasi queue tree untuk client 3

[admin@MikroTik] /ip firewall mangle> /queue tree
[admin@MikroTik] /queue tree> add name=client3-downlink parent=lan
limit-at=96000 packet-mark=client3 max-limit=192000
[admin@MikroTik] /queue tree> add name=client3-uplink parent=wan
limit-at=32000 packet-mark=client3 max-limit=64000
[admin@MikroTik] /queue tree> print
Flags: X – disabled, I – invalid
0  name=”client1-downlink” parent=lan packet-mark=client1
limitat=96k queue=default priority=8 max-limit=192k burstlimit=0
burst-threshold=0
burst-time=0s

1  name=”client1-uplink” parent=wan packet-mark=client1
limitat=32k queue=default priority=8 max-limit=64k burstlimit=0
burst-threshold=0
burst-time=0s

2  name=”client2-downlink” parent=lan packet-mark=client2
limitat=96k queue=default priority=8 max-limit=192k burstlimit=0
burst-threshold=0
burst-time=0s

3  name=”client2-uplink” parent=wan packet-mark=client2
limitat=32k queue=default priority=8 max-limit=64k burstlimit=0
burst-threshold=0
burst-time=0s

4  name=”client3-uplink” parent=wan packet-mark=client3
limitat=32k queue=default priority=8 max-limit=64k burst-
limit=0 burst-threshold=0 burst-time=0s
5  name=”client3-downlink” parent=lan packet-mark=client3
limitat=96k queue=default priority=8 max-limit=192k burstlimit=0
burst-threshold=0
burst-time=0s

[admin@MikroTik] /queue tree>

Itulah selesai sudah langkah konfigurasinya, untuk cek bandwidth silahkan kunjungi situs check speed connection seperti speedtest.net dan lain-lain. Terima kasih.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s